Opened 12 years ago

Closed 11 years ago

#405 closed defect (fixed)

Disaggregation throws exception when attempting to disaggregate empty (all zeros) hazard curve

Reported by: bakerjw@… Owned by:
Priority: major Milestone: OpenSHA 1.3
Component: sha Version: 1.2.3
Keywords: GCIM_HazardCurve Cc:


Steps to reproduce: (PLEASE FILL IN)

Other info: (PLEASE FILL IN)

Application: GCIM_HazardCurve
Version: 1.2.3
Bulid Type: Production
Java Version: 1.7.0_05 (Oracle Corporation)
Operating System: Windows 7 (arch: x86, version: 6.1)


org.opensha.commons.exceptions.ConstraintException: SA Interpolated: setValue(): Value is not allowed: -Infinity
	at org.opensha.commons.param.AbstractParameter.setValue(
	at org.opensha.commons.param.impl.WarningDoubleParameter.setValueIgnoreWarning(
	at org.opensha.commons.param.impl.WarningDoubleParameter.setValueIgnoreWarning(
	at org.opensha.sha.gcim.calc.DisaggregationCalculator.disaggregate(
	at org.opensha.sha.gcim.calc.GcimCalculator.getRuptureContributions(
	at org.opensha.sha.gcim.ui.GCIM_HazardCurveApp.computeHazardCurve(
	at Source)


Cacluation Type = Probabilistic

IMR Param List:

IMR = Interp Abrahamson & Silva (2008); Gaussian Truncation = None; Tectonic Region = Active Shallow Crust; Component = Average Horizontal (GMRotI50); Std Dev Type = Total

Site Param List:

Longitude = -118.2467; Latitude = 34.055; Vs30 = 760.0; Vs30 Type = Inferred; Depth 1.0 km/sec = 100.0

IMT Param List:

IMT = SA Interpolated; SA Interpolated Period = 1.0; SA Damping = 5.0

Forecast Param List:

Change History (3)

comment:1 Changed 11 years ago by Kevin Milner

Resolution: worksforme
Status: newclosed

Sorry for the incredibly late response. I couldn't reproduce this bug so I'm marking it as 'worksforme'. It is possible that it has been solved since the previous release. If you experience this bug again, please resubmit with steps to reproduce filled in. Thanks!

comment:2 Changed 11 years ago by Kevin Milner

Milestone: OpenSHA 1.3
Resolution: worksforme
Status: closedreopened
Summary: Bug in GCIM_HazardCurveDisaggregation throws exception when attempting to disaggregate empty (all zeros) hazard curve

Actually I was just able to reproduce this bug. This happens when you try to disaggregate on an empty hazard curve (such as when your site isn't within the cutoff distance of any ruptures in the selected ERF, for example site in California for Eastern US ERF).

comment:3 Changed 11 years ago by Kevin Milner

Resolution: fixed
Status: reopenedclosed

I have fixed it to show an error message instead of throwing an exeption in [10271]. Fix will be included in OpenSHA 1.3 release.

Note: See TracTickets for help on using tickets.